GPS funktioniert mit 98% fix - an einer Stelle Nähe Haus / Garagenwand gar nicht - Tipps Filter tweaking?

Ghost

Member
Erstmal bin ich sehr zufrieden mit den ersten Mähversuchen :)

Ein fast perfekter Start nach erstmaligem Einlernen der Karten:

Zu 98% fix und otptimale Ergebnisse, auch am Rand.
Nur an 2 Stellen - enge Durchfahrt nahe an Garagenwand (50cm) Reflexion und Abschattung durch Haus geht leider nichts mehr, er parkt leider dauerhaft.
Satellitten sind genug da - 35 Stück, float 0,02-0,08 schwankend. Da die Stelle genau am äußersten Rand ist, kann ich Ihn nicht zulange ohne Fix fahren lassen, er fährt dann leider in die Garagenbeete - 2-3m weiter funktioniert alles mit Fix.

An welchen Filtereinstellungen kann ich zu erst versuchen zu tweaken?
Hat dies Auswirkungen auf die Genauigkeit/Zuverlässigkeit auf dem Rest der Fläche?

#define CPG_CONFIG_FILTER_MINELEV 10 // Min SV elevation degree: 14 (high elevation, less robust), 10 (low elevation, robust)
#define CPG_CONFIG_FILTER_NCNOTHRS 10 // C/N0 Threshold #SVs: 10 (robust), 6 (less robust)
#define CPG_CONFIG_FILTER_CNOTHRS 30 // 30 dbHz (robust), 13 dbHz (less robust)

Besten Dank für Tipps

:):)
 
Zuletzt bearbeitet:

W1976

Well-known member
Teammitglied
Da die Stelle genau am äußersten Rand ist, kann ich Ihn nicht zulange ohne Fix fahren lassen, er fährt dann leider in die Garagenbeete - 2-3m weiter funktioniert alles mit Fix
Hattest du beim Abfahren des virtuellen Begrenzungsdraht da einen fix? Sonst musst du da nochmal schauen. Hatte auch an der Garagenwand Probleme und hatte ohne fix, den GPS Punkt am Eck gesetzt, da ist mein Ardumower dann in die Steinrabatte reingefahren...weil der GPS Punkt wegen float an der falschen Stelle war.

Du musst mal schauen, wegen den Filtern. Da hatte Kermi schon was geschrieben gehabt. Oder ihn einfach mal anschreiben.

In der APP kannst du mit dem Schieberegler "Fix timeouts(s)" die Sekunden festlegen, wie lange er ohne fix fahren darf.

Der Mower sollte auf jeden Fall nicht mit invalid fahren, siehe cofig_h hier:

#define REQUIRE_VALID_GPS true // mower will pause if no float and no fix GPS solution during mowing (recommended)
//#define REQUIRE_VALID_GPS false // mower will continue to mow if no float or no fix solution (not recommended)
 

Ghost

Member
Ja - fix war beim erstellen der Karte da...

Der Rover kommt aus einer Ecke, wo wegen Grillhütte der Empfang schon leicht schlechter wird, er sicht aber noch gut hält. Fix time out ist 10sec - er fährt auch im "unkritischen Bereich" wo die Genauigkeit nicht so wichtig ist.
Genau am äussersten Punkt in der Nähe der Wand ist dann Schluß für 2-3 Meter, leider brauche ich da die Genauigkeit....

GPS steht auf valid true in Config.h
 

kermi

Well-known member
Hi Ghost,

ja, es gibt Stellen wo es wirklich nicht so einfach ist mit dem GPS FIX. Sehr viel machen kannst du da auch nicht.
Ich fahre mit folgenden Einstellungen in der config.h:

#define CPG_CONFIG_FILTER_MINELEV 13 //
#define CPG_CONFIG_FILTER_NCNOTHRS 7 //
#define CPG_CONFIG_FILTER_CNOTHRS 14 //

Diese Einstellungen habe schon einen gewissen Einfluss auf das FIX/FLOAT Verhalten.
Ein GENERELLES besser oder schlechter gibt es nicht so wirklich, es ist bei jedem etwas anders. Auch nicht jeder Tag ist gleich. Es gibt Tage da habe ich guten Empfang und es gibt Tage das ist es grotte.

Du solltest mit den oben genannten Einstellungen und dem FIX TimeOut in der App spielen, das erfordert etwas Zeit und Beobachtung bis du für dich die optimalen Einstellung gefunden hast.
 

Ghost

Member
Danke kermi und W1976...

Ich werde mal mit Deinen Parametern anfangen und mich dann in verschiedene Richtungen vortasten.
Ist wirklich nur eine Ecke, aber die wo er im Garagenbeet landet ;-)
 

Ghost

Member
Hallo Kermi,
mit Deinen Einstellungen ist er an der Aussenumrandung perfekt gefahren ;-)
Nur für 2 Sekunden Float und direkt wieder Fix.

Wo sind denn die Nachteile gegenüber den Originalwerten (höhere Gefahr von Jumps?, größere Ungenauigkeiten - obwohl 2cm sind 2cm)...

Macht es Sinn wieder etwas restrikter zu werden - wie gesagt - Deine Einstellungen beim 1. Lauf perfekt am Rand
Hi Ghost,

ja, es gibt Stellen wo es wirklich nicht so einfach ist mit dem GPS FIX. Sehr viel machen kannst du da auch nicht.
Ich fahre mit folgenden Einstellungen in der config.h:

#define CPG_CONFIG_FILTER_MINELEV 13 //
#define CPG_CONFIG_FILTER_NCNOTHRS 7 //
#define CPG_CONFIG_FILTER_CNOTHRS 14 //

Diese Einstellungen habe schon einen gewissen Einfluss auf das FIX/FLOAT Verhalten.
Ein GENERELLES besser oder schlechter gibt es nicht so wirklich, es ist bei jedem etwas anders. Auch nicht jeder Tag ist gleich. Es gibt Tage da habe ich guten Empfang und es gibt Tage das ist es grotte.

Du solltest mit den oben genannten Einstellungen und dem FIX TimeOut in der App spielen, das erfordert etwas Zeit und Beobachtung bis du für dich die optimalen Einstellung gefunden hast.

(meine Kantsteine sind 20cm breit, da ist Präzison am Rand schon sehr wichtig)...

Danke nochmal :):)
 

W1976

Well-known member
Teammitglied
Vielleicht mal die Ublox Firmware 1.30 anstatt der 1.13 probieren. Es gibt Hinweise das die vielleicht noch etwas besser ist im Signal Empfang. Die Fehlermeldungen beim Installieren kann man wohl vernachlässigen, lt. Alexander.

Ich will sie auch noch probieren, wenn mal wieder das Wetter besser wird.
 

kermi

Well-known member
Hallo Kermi,
mit Deinen Einstellungen ist er an der Aussenumrandung perfekt gefahren ;-)
Nur für 2 Sekunden Float und direkt wieder Fix.

Wo sind denn die Nachteile gegenüber den Originalwerten (höhere Gefahr von Jumps?, größere Ungenauigkeiten - obwohl 2cm sind 2cm)...

Macht es Sinn wieder etwas restrikter zu werden - wie gesagt - Deine Einstellungen beim 1. Lauf perfekt am Rand


(meine Kantsteine sind 20cm breit, da ist Präzison am Rand schon sehr wichtig)...

Danke nochmal :):)
naja, Alexander seine Filter sind sehr restriktiv, also wenn der Mover dann FIX hat ist er auch sehr genau.
Leider habe ich mit Alexanders restriktiven Einstellungen an einigen Stellen nur Float.

Du kannst dir das in ungefähr so vorstellen das der Mover mit meinen lockeren Einstellungen leichter einen FIX bekommt, dieser kann allerdings auch mal etwas daneben liegen wobei ich diese Erfahrung noch nicht gemacht habe.

Freue dich bitte nicht zu früh, teste es an mehreren Tage aus, wie gesagt, jeder Tag ist anders (Luftfeuchtigkeit, Schwebepartikel in der oberen Atmosphäre, Sonnenstrahlung, ach, keinen Ahnung was da alles für Faktoren mit reinspielen).
 

kermi

Well-known member
Vielleicht mal die Ublox Firmware 1.30 anstatt der 1.13 probieren. Es gibt Hinweise das die vielleicht noch etwas besser ist im Signal Empfang. Die Fehlermeldungen beim Installieren kann man wohl vernachlässigen, lt. Alexander.

Ich will sie auch noch probieren, wenn mal wieder das Wetter besser wird.
ja, wäre auch eine Möglichkeit. Da ich allerdings momentan mit Einstellungen relativ zufrieden bin werde ich erst einmal auf Erfahrungsberichte warten, nicht das ich die Hauptkomponente verschlimmbessere. Ich weiss nicht ob es einfach so möglich ist von 1.30 wieder auf 1.13 zu downgraden?!
 

kermi

Well-known member
@Ghost : im übrigen sind 98% FIX ein sehr guter Wert. Du kannst ja dann auch testweise deine Einstellungen bzw. die Filter langsam verschärfen falls du merkst das er trotz FIX ein paar cm zu ungenau ist. Einfach wieder in Richtung der Filter von Alexander die doch sehr genau sind.
 

W1976

Well-known member
Teammitglied
Downgraden geht, hatte die 1.30 schon drauf. Wusste aber damals noch nicht ob die Fehlermeldungen die beim installieren der 1.30 was ausmachen. Und habe deshalb wieder die 1.13 installiert. Und zwar die original von Ardusimple. Danach die Einstellungen nach Sunray Wiki gemacht.
 

Hartmut

Active member
Fix kann man auch Verbessern wenn du eine 20cm 3mm dicke Metallgrundplatte verwendest. Dann kann man auch signalstärkere Antennen verwenden. Die Antennen bringen unterschiedliche Verbesserungen je nach Eigenheit deines Grundstückes. Aber erstmals den halben Sommer testen. Ich habe auch eine solche Stelle mit wenig fix. Es ist einfacher mit den Akkutrimmer da alle 14 Tage mal den Rasen zu trimmen.
 

Ghost

Member
Es sind nur 4m im gesamten Grundstück - leider die genau an der Wand, aber die ganz am Anfang des Mähvorgangs. Aber ich teste mich ran und bin sicher das er im Laufe der Zeit zu 100% sicher fährt.

:) bin sehr zufrieden wie er so mäht....
 

W1976

Well-known member
Teammitglied
Kermi, hast du auch noch was an der UBlox geändert oder greift die Config.h auf die Ublox zu?
 
Oben